Equisys technical notes

Technical guidance, explanations and fixes for our products

FIX: When printing to Zetafax printer the printer displays an error

Print

ZTN2107

ID: ZTN2107

This Zetafax technical note applies to:

  • Zetafax Client v17

Symptom

When a user prints a document to the Zetafax printer the printer will show an error saying “You must finish addressing the previous fax”.

Cause

This error shows when the client does not open fast enough. The default waiting time for the client to open is set to 1 second and when the client takes longer than that to open the printer displays the message above.

Resolution

An update is available here to address this issue. This new update will change the default waiting time to 10 seconds allowing slower machines to cope with slower times when opening the Zetafax Client. Initial print start message is now retried if client is busy (default 10 seconds).

Registry Editor warning

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Equisys cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved.

The following registry keys are now available to modify the waiting time before throwing an error. (Please note that this is an advanced option for users wishing to modify the default fix behaviour and is not required):

  • HKLM\Software\Equisys\Zetafax:

·         ClientLaunchWait – timeout in seconds between launching the client EXE and the application starting.

·         ClientBusyWait1 – timeout for client to end BUSY state when first printing a document.

·         ClientBusyWait2 – timeout for client to end BUSY state after user clicks Retry while printing a document

Status

This behaviour was corrected in the update detailed above.

Last updated: 5thAugust  2016 (JC/NT) 

Keywords: Zetafax client, Error, Start client

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script