Equisys technical notes

Technical guidance, explanations and fixes for our products

FIX: SMTP gateway generates a 'Not a ZF recipient' error.

Print

ZTN1774

ID: ZTN1774

This Zetafax technical note applies to:

  • Zetafax SMTP gateway version 2009 and earlier

Symptom

When sending faxes via the Zetafax SMTP gateway, it produces an error in the log file similar to the following:

“Not a ZF recipient (02999888777@fax)”.

Cause

This happens when the SMTP gateway receives a message which has different addresses in the SMTP “RCPT TO:” field and in the “DATA To:” header, i.e. the recipients don’t match.

Resolution

A hotfix is available for this issue to all Software Assurance customers, contact your local distributor or Equisys at sales@equisys.com with your entitlement details to obtain these passwords.

To apply the hotfix please do the following:

  • Download the hotfix from the following location:

ZTN1774Hotfix.rar

  • Extract the hotfix to a temporary location
  • Navigate to C:\Program Files\Zetafax SMTP Server\ and rename zfsmtpgw.exe to zfsmtpgw.exe.old
  • Copy the new version of zfsmtpgw.exe into the folder
  • You now need to add a key into the registry to disable the recipient address comparison:

Registry Editor Warning

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Equisys cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved.

For information about how to edit the registry, view the " Changing Keys and Values" Help topic in Registry Editor (REGEDIT.EXE) or the " Add and Delete Information in the Registry" and " Edit Registry Data" Help topics in REGEDT32.EXE. Note that you should back up the registry before you edit it.

  • Log onto the machine using an account that has local machine administrative privileges.
  • From the start menu, click Run.
  • Type the following: regedit
  • Click OK.
  • In the Registry Editor, navigate to the following registry key:
  • HKEY_LOCAL_SYSTEM\Software\Equisys\Zetafax SMTP Server
  • Create a new string key called OverrideAddressCheck.
  • Give it a value of “yes”.
  • Restart the Zetafax SMTP service.

Status

This behaviour was corrected as a patch to Zetafax Server v2009 Platform Feature Pack.

Last updated: 21 April 2010 (JN/MW)

Keywords: SMTP Not a ZF recipient

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script