Equisys technical notes

Technical guidance, explanations and fixes for our products

FIX: When printing a batch with documents, the order of printing is not correct

Print

ZTN3611

ID: ZTN3611

This Zetadocs technical note applies to:

  • Zetadocs PDF client v9 and earlier

Symptom

When a batch contains documents with the same name, documents are named with numerical postfixes in the Windows standard (for instance, Statement, Statement(1), Statement(2) etc.). If these numerical postfixes go above 9, Zetadocs PDF may load the documents within the batch in an unexpected order:

When printing this batch, this ordering is maintained, so the documents are printed out of sequence. Reordering the documents using the sorting columns in Zetadocs PDF does not have any effect on the print order.

Cause

This was caused by the ordering logic in Zetadocs PDF not catering for documents that have duplicate names.

Resolution

This fault was corrected in a hotfix, which is available by contacting Equisys Technical Support and quoting the technote number ZTN3611.

Status

This behaviour was corrected in the hotfix detailed above.

Last updated: 14th August 2015 (JC/NT) 

Keywords: alphabetical order, numerical order

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script