Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Inbound faxes and fax notifications are not received by Exchange 2007

Print

ZTN1671

ID: ZTN1671

This Zetafax technical note applies to:

  • Zetafax 2007
  • Microsoft Exchange 2007
  • Exclaimer mail utilities 2007

Symptom

Received faxes and notifications of successfully sent faxes are not received by the Outlook inbox when using the Zetafax Exchange 2007 connector.

The fax messages are picked up from Exchange\pickup directory successfully however never reach the mailbox.

Cause

There is an incompatibility with Zetafax messages in the Pickup directory and certain Transport agents. An example is Exclaimer mail utilities.

You can get a list of the transport agents running on the Hub transport bridgehead, using the get-transportagent cmdlet.

If you see ExclaimerSMTPagent and ExclaimerRoutingAgent or similar this will be the cause of messages not getting delivered. To confirm this you can temporarily disable these agents by running disable-transportagent and following the shell prompts to disable it. Restart the Exchange Transport service to see if Zetafax messages now placed in the pickup directory are delivered.

Resolution

Create a custom rule so that the Transport agents do not process messages with a header of:

From: " Zetafax" < Zetafax@Zetafax.fax>

With Exclaimer, you can do that as follows:

  1. Open the Exclaimer Control Panel.
  2. Go to the Custom Rules screen and click the “Add Rule” button.
  3. On the Addressing tab, set the “Recipient” to “Anyone” and set the “Sender” to " Message Header Equals" . In the field below enter the following text exactly as it appears including the stars:


  4. From:*Zetafax*

  5. Go to the Disclaimers tab and set the Disclaimer drop-down field to “Don't add disclaimer" .
  6. Give the rule a name e.g. Zetafax.
  7. Press OK.
  8. Press Save.
  9. Depending on how many rules you have, you may need to list this rule highest for it to take precedence.

Status

This has been identified by Equisys as a problem with the software versions given above.

References

ZTN1650 - PRB: Inbound faxes do not arrive at Exchange 2007 mailboxes - http://www.equisys.com/technotes/ztn1650.htm.

Last updated: 22 May 2008 (GC/DH)

Keywords: < connector> < routing>

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script