Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Mapiexp.exe fails on Exchange 2003 Server

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ZTN1366

ID: ZTN1366

This Zetafax technical note applies to:

  • Zetafax Email Gateway
  • Microsoft Exchange 2003
  • Microsoft Outlook XP

Symptoms

When exporting users from Exchange during configuration of the email gateway, the MAPIEXP program fails with the following error:

MAPIInitialize failure

or

MAPI Initialization failure

This occurs if Zetafax and Outlook XP are both installed on an Exchange Server 2003 server.

Cause

MAPIEXP uses the default mail profile for the user to log on to the Exchange Server and export all the users that are present in the Global Address List. When Outlook XP is installed on the machine, it creates a default profile called " Outlook" . MAPIEXP does not work with this profile, nor does the MAPI tool mdbvu32.exe.

Resolution

Recreate the default mail profile for the user as follows:

  1. Open Control Panel
  2. Open Mail applet
  3. Click on the Show Profiles button
  4. Click on the Add button
  5. Create a new profile for the user
  6. Now set the new profile as the default by choosing " Always use this profile" and selecting it from the drop-down list as shown below:

  1. Press OK and run MAPIEXP to export Exchange users.
  2. Once you have confirmed the new profile is working, remove the Outlook profile.

Workaround

The following workarounds are available:

Log on as another user who does not have a default " Outlook" profile. Go to Control Panel / Mail, and create a profile for the user. Run MAPIEXP - it will now use this profile.

Status

This has been identified by Equisys as a problem with the software versions given above.

Last updated: 19th March 2003 (SD/SV)

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