PRB: Modem trace log is virtually empty
Print
ZTN1328
ID: ZTN1328
This Zetafax technical note applies to:
Symptom
When enabling a modem trace log to troubleshoot a problem (see ZTN1065-INFO: Enabling detailed logging within Zetafax), you may find that the resulting trace log only has a few lines, as in the example below:
03-09-23 14:33:23 FCLASS-1 - (I) - Configured for generic Class 1 / Class 2 modem
03-09-23 14:33:23 FCLASS-1 - (-) - Opening COM port
03-09-23 14:33:23 FCLASS-1 - (-) - SetupRS232() - baud = 19200, CTS timeout = 0 ms
03-09-23 14:33:23 FCLASS-1 - (-) - Poll - 'ATE0V0Q0S0=0& C1& D2M0L2', Reply - < none>
03-09-23 14:33:25 FCLASS-1 - (-) - Checking Fax status
03-09-23 14:33:25 FCLASS-1 - (-) - Poll - 'ATE0V0Q0S0=0& C1& D2M0L2', Reply - OK
03-09-23 14:33:25 FCLASS-1 - (-) - Start SelectServiceClass(): 1064320405.628
03-09-23 14:33:25 FCLASS-1 - (-) - Poll - 'AT+FCLASS=?', Reply - " 0,1,2,8"
03-09-23 14:33:26 FCLASS-1 - (-) - Failed to set to ServiceClass 1.0 (choice 1)
03-09-23 14:33:26 FCLASS-1 - (-) - Poll - 'AT+FCLASS=1', Reply - OK
03-09-23 14:33:26 FCLASS-1 - (I) - Modem set to Class 1
03-09-23 14:33:26 FCLASS-1 - (-) - End SelectServiceClass(): 1064320406.550
03-09-23 14:33:26 FCLASS-1 - (-) - Poll - 'AT+FCLASS=0', Reply - OK
03-09-23 14:33:26 FCLASS-1 - (-) - Closing COM port
Cause
This behaviour occurs if the modem is not configured to receive. In this case, the modem port is closed as soon as initialisation is completed, and logging does not occur beyond that point.
Resolution
There are two ways to work around this behaviour:
- Set a default recipient to receive faxes in Zetafax Configuration, Devices
OR
- Add the following line to the [FCLASS-x] section in SETUP.INI for each modem port:
KeepPortOpen: YES
Either of these settings will force the modem port to stay open, which will allow logging to continue.
Status
Last reviewed: 11 November 2005 (GC/EB)
Date Published: 11 November 2005 (EB/SV)