Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: NAV Client with Zetadocs addin crashes after applying NAV hotfix

Print

ZTN4250

ID: ZTN4250

This Zetadocs technical note applies to:

  • Version 5 and later of Zetadocs for Microsoft Dynamics NAV

Symptom

After applying a NAV hotfix to a NAV environment which has Zetadocs for NAV installed, without re-compiling the NAV objects, when a page that contains the Zetadocs addin is viewed the NAV client crashes.

Cause

After applying a NAV hotfix several objects might be updated thus functions that are referencing or using those updated objects will be out of sync and might not work as expected.

Resolution

Microsoft recommends re-compiling all the NAV objects in either the Classic Client or the NAV Development Environment depending on the version of NAV used, after applying a NAV hotfix. This will resolve the above issue.

Status

This has been identified by Equisys as a problem with the software versions given above.

Last updated: 15th May 2013 (AT/MW)

Keywords: NAV Client crash after applying hotfix

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script