PRB: 'The SMTP server requires a secure connection or the client was not authenticated' error when using Zetadocs Delivery
Print
ZTN4617
This Zetadocs technical note applies to:
- Zetadocs Delivery
- Systems that currently send email using Exchange Online (smtp.office365.com) with Basic Authentication
Symptom
When using Exchange Online SMTP with Basic Authentication (App Password), Zetadocs Delivery fails with the error in the logs:
“The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.57 Client not authenticated to send mail. Error: 535 5.7.3 Authentication unsuccessful” .
Cause
From September 2025, Microsoft is removing the possibility to connect to Exchange using SMTP with Basic Authentication (App Password). Some environments may have had security settings applied that pre-emptively disable the SMTP AUTH support and these environments will experience the error earlier than the September date.
Resolution
Following Microsoft recommendation, your Azure environment can be setup to allow sending via SMTP settings using Azure Communication Services. Those settings are fully compatible with Zetadocs Delivery.
Status
The SMTP settings can be updated to stay compatible with Zetadocs Delivery. Please follow the technote ZTN4616.
Last updated: 11th March 2025 (CR/NT)
Keywords: Zetadocs Delivery SMTP Fails Microsoft Authentication