Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Zetadocs Archive Service does not start automatically after reboot

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ZTN4314

ID: ZTN4314

This Zetadocs technical note applies to:

  • Version 6.0 of Zetadocs for Microsoft Dynamics NAV and above
  • Version 1.0 of Zetadocs Archive

Symptom

After a reboot of the machine where the Zetadocs Archive Service is installed, the Zetadocs Archive Service is not in the Started state despite having a Startup Type of “Automatic”.

This issue occurs on machines that are under heavy load and are running a large number of services.

Cause

The Zetadocs Archive Service does attempt to start when the machine starts, but fails due to a timeout.

Resolution

If the Zetadocs Archive Service is running on Windows Server 2008 or above, the startup type of the service can be changed to “Automatic (Delayed Start)”.  This will give Windows more time to load before attempting to start the Zetadocs Archive Service and so there should be more resources available when it does attempt to start.

If the Zetadocs Archive Service is running on an older operating system or delayed start does not solve the problem then a registry key can be changed to allow the service more time to start.  To do this, please follow the instructions here: http://support.microsoft.com/kb/922918

Registry Editor warning

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Equisys cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved.

Status

Equisys is aware of this issue and will update this technical note when a solution has been found.

Last updated: 18th December 2013 (JW/MW)

Keywords: archive service restart start

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