Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Zetafax connector fails to run on windows 2003 Small Business Sever.

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ZTN1335

ID: ZTN1335

This Zetafax technical note applies to:

  • Zetafax Connector Version 8.0.1.118 or later.

Symptom

After installing the Zetafax connector on a Windows 2003 SBS (Small Business Server), it appears to run without any issues but messages are not passed to or from the Exchange MTA (Message Transfer Agent).

Another symptom on some systems you will be able to install the connector but it will fail to start with the error message "Error 1068: The dependency service or group failed to start".   This is because Exchange has not been fully configured and the Connector service is failing to start as the MTA is set to disabled.

Cause

This issue arises because the MTA is disabled by default in SBS 2003. The MTA is no longer used by Microsoft Exchange to pass messages, but it is still used by third party connectors like the Zetafax connector.

Resolution

It is possible to re-enable the MTA by following the procedures below.

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Equisys cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved.

For information about how to edit the registry, view the " Changing Keys and Values" Help topic in Registry Editor (REGEDIT.EXE) or the " Add and Delete Information in the Registry" and " Edit Registry Data" Help topics in REGEDT32.EXE. Note that you should back up the registry before you edit it. If you are running Windows NT or Windows 2000, you should also update your Emergency Repair Disk (ERD).

Remove relevant registry keys:

  1. On the SBS system run the Registry Editor (Regedit.exe)
  2. Navigate to the following key (this line may wrap - you need to look for the whole name):

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\< servername> \Private-< guid>

Where < servername> is the name of the server, and < guid> is a GUID (globally unique identifier) As below.

  1. Remove the following two entries from this key:

" Gateway In Threads"

" Gateway Out Threads"

  1. Navigate to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\< servername> \Public-< guid>

Where < servername> is the name of the server, and < guid> is a GUID (globally unique identifier) As below.

  1. Remove the following two entries from this key:

" Gateway In Threads"

" Gateway Out Threads"

  1. Close regedit.exe.

Now you need to change the startup type of the Microsoft Exchange MTA Stacks service and restart the System Attendant and Zetafax Connector. Follow these steps.

  1. Open the Services MMC in Administrative Tools.
  2. Edit the Properties of the Microsoft Exchange MTA Stacks as below.

  1. In the General tab, change the Startup type from Disabled to Automatic.
  2. Click Apply and then start the service. Close the properties dialog box.
  3. While still in the Services MMC, re-start the Microsoft Exchange System Attendant service. This will also re-start all dependant services.
  4. Restart the Zetafax Connector service

Note: Users may still report that faxes submitted via outlook are returned with NDR's (Non Delivery Report) with the following message:

  1. This is problem can occur if some of the exchange services have not started up correctly or have not been restarted after working through this technical note. Verify that you have restarted the exchange server services and the Zetafax connector service.

Status

This has been identified by Equisys as an issue with the software versions given above.

Last updated: 21st April 2004 (SV/DH)

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