Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Zetafax Server service fails to initialise Brooktrout cards on startup

Print

ZTN1124

ID: ZTN1124

This Zetafax technical note applies to:

  • Zetafax 5.5 and later

Symptom

When the Zetafax server service is set to start automatically at startup, the Zetafax server is unable to initialise the Brooktrout cards. If the service starts later manually or is restarted then the Zetafax server service starts with no issues.

Cause

The Brooktrout device driver (BFAX) is not able to start correctly on system startup. If the driver is reinitialised or started later, then starts correctly.

Resolution

Choose one of the following:

  1. Set the Zetafax server service to manual using the 'Services' applet in 'Control panel' and start the service after the system has started.
  2. Restart the Zetafax server service from the 'Zetafax server monitor' after the system has started.
  3. Set the Zetafax server service to a manual startup and use the NT resource kit tools, 'AUTOEXENT.EXE' and 'SLEEP.EXE' to automate starting the service later.

'AUTOEXENT.EXE' is a Windows NT service that runs a batch file at system startup. Install the service from the NT resource kit and follow the instructions on where to create the batch file to run the Zetafax server service at a later time. This batch file can be delayed using the NT resource kit tool 'SLEEP.EXE'. 'SLEEP.EXE' adds a pause to a batch file. Create a batch file with the following two lines.

Sleep 120

net start "Zetafax Server"

The batch file will start the service automatically when the Zetafax server machine is restarted.

Status

Last updated: 15 February 2001 (JG/DH)

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script