FIX: Zetadocs Client hangs when trying to load printed documents
Print
ZTN4195
ID: ZTN4195
This Zetadocs technical note applies to:
- Zetadocs PDF version 8.0 or earlier
- Zetadocs for NAV (versions 4.0 to 5.0) with the Zetadocs Client version 8.0 or earlier
Symptom
When printing a document from NAV or any other application to the Zetadocs PDF printer:
Zetadocs Client hangs and shows an error message that says “Given key not present in Dictionary” after starting up.
OR
Zetadocs Client crashes.
Cause
The Zetadocs Client tries to load files produced by the printer when it starts up. Sometimes those files can be invalid and Zetadocs was failing to deal with the errors when dealing with invalid printer files. The files involved are group files and contain necessary information about the print job that the Zetadocs Client processes.
This issue can be caused by:
Printing an empty document. (e.g. open notepad and print without any text)
OR
The printing action gets interrupted or corrupted.
Resolution
Version 5.0 of Zetadocs for NAV Systems
This issue has been resolved in the Version 5.0 of Zetadocs for NAV Platform Feature Pack, available for download here.
Version 4.2 of Zetadocs for NAV Systems
This issue has been resolved in an update available for download here.
Status
This fault was corrected via an update and in the Version 5.0 of Zetadocs for NAV Platform Feature Pack
Last updated: 24th January 2013 (AT/MW)
Keywords: Zetadocs Client hangs when printing an empty document or a document with an invalid group file