PRB: MRS fails to render attachments when Zetafax is running as a service on Windows 2003 SP1
Print
ZTN1481
ID: ZTN1481
This Zetafax technical note applies to:
- Zetafax 9.1
- Microsoft Windows 2003 Service Pack 1
Symptom
When sending faxes via the Email Gateway, and using the Mail Rendering Sub-system printer (MRS) to render them, attachments fail to render.
The user sending the fax, receives email notification that their fax has been rejected, with a 'Status code' of '63243'
When the administrator checks the Zetafax Server monitor, a similar message of events can be seen.
05-07-14 09:21:46 STOLE - (I) - Conversion in progress for: test.doc
05-07-14 09:22:47 STOLE - (I) - Conversion failed
05-07-14 09:22:47 STOLE - (I) - Message rejected
05-07-14 09:22:47 STOLE - (I) - Unable to process message
05-07-14 09:22:47 STOLE - (I) - Status reply returned
05-07-14 09:22:48 STMAIL - (I) - Passing message to mail system
Cause
This issue appears to have been caused, by the enhanced security of Windows 2003 Service Pack 1, due to the stronger defaults and privilege reduction on services. For technical details on Windows 2003 SP1 read,
http://www.microsoft.com/technet/prodtechnol/windowsserver2003/servicepack/overview.mspx
Resolution
Method one
Set Zetafax server to run as an application, not as a service.
Method two
In some cases this issue has been resolved by setting the Zetafax Server service, to log on using the LocalSystem account, then allowing this service to interact with the desktop.
To do this
- Form the Start menu, select Run, and type Services.mscto open the Service MMC snap-in.
- Locate and stop the Zetafax Server service.
- Double-click the Zetafax Server service.
- On the Log On tab of the Zetafax Server Properties page, select Local System account under Log on as.
- Tick the Allow service to interact with desktop check box, and then click Apply.
- Under Service status, click Start, and then click OK.
- Close the Services snap-in.
If the Zetafax Server and the Exchange server are on two separate machines, the Exchsrvr\CONNECT folder on the Exchange server needs to have additional permissions added.
To do this
- Using Windows Explorer, on the Exchange server,browse to < ProgramFiles> \Exchsrvr\CONNECT
- Right-click the CONNECT folder, click Properties, select the Sharing tab.
- Ensure that the folder is shared, click the Permissions button.
- Click the Add button, in the Enter the object names to select box, type Everyone, click OK.
- Highlight the Everyone group, tick the Full Control item.
- Click Apply, click OK to close the share permissions dialog, select the Security tab.
- Click the Add button, in the Enter the object names to select box, type Everyone, click OK.
- Highlight the Everyone group, tick the Full Control item.
- Click Apply, and OK to close the Properties dialog
Status
This has been identified by Equisys as a problem with the software versions given above.
Keywords: SP1, Service Pack 1, unable to render, attachments fail, Exchsvr
Last reviewed: 11 November 2005 (GC/EB)
Date Published: 14 July 2005 (MS/SV)