FIX: Zetadocs Delivery fails to send after Basic authentication disabled in Exchange Online
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ZTN4577
This Zetadocs technical note applies to:
- Zetadocs Delivery when sending using SMTP with Exchange Online
- Zetadocs Extension for Business Central version 2.0 and later
- Zetadocs for NAV version 9.0 and later
Symptom
When using Zetadocs Delivery to send a record you are given an error message "Authentication using SMTP credentials is disabled.".
Alternativaly for early versions of Zetadocs Extension, you are given a generic error message "Zetadocs has encountered an error when making the webapi request. Please contact your administrator." or if you are using Zetadocs for NAV "Error sending the message. Please review the Zetadocs Delivery Outbox and the Zetadocs Delivery Settings.".
To understand if this the resolution in this technote applies to you, install the ExchangePowerShell and ExchangeOnlineManagement PowerShell Modules. Run the following PowerShell script to check your authentication settings, where <YourMailboxIdentity> is the email address from your Zetadocs Delivery Settings e.g. accounts@contoso.com and logging in with an Exchange Adminstrator account when prompted.
Connect-ExchangeOnline
Get-CASMailbox -Identity <YourMailboxIdentity> | Format-List SmtpClientAuthenticationDisabled
If the output is "SmtpClientAuthenticationDisabled : True" then your account has had SMTP Auth disabled and so you will need to follow the steps in the Resolution section in order to use Zetadocs Delivery.
If the output is "SmtpClientAuthenticationDisabled : False" this technote does not apply to you and you should contact your VAR/Equisys to help resolve your problem.
Cause
In October 2022 Microsoft deprecated Basic Authentication for Exchange Online. As part of this they set security defaults where SMTP Authentication for all new tenants are disabled. SMTP Auth can be re-enabled as it is still needed by many multi-function devices such as printers and scanners that can't be updated to use modern authentication.
In order to check if the cause is due to the authentication method not being correct, please follow the steps in the following technical note: HOWTO: Test SMTP on Exchange Online is working for use with Zetadocs
Resolution
Please ensure that within Azure 'Enable security defaults' are set to 'No' (Providing a default level of security in Azure Active Directory - Microsoft Entra | Microsoft Learn) and then follow HOWTO: Use Zetadocs Delivery with Exchange Online and to get Zetadocs Delivery working again.
Status
A solution for this behaviour is detailed in the technote mentioned above.
Last updated: 7th October 2022 (MP/CR)
Keywords: Zetadocs Delivery, Email, Send, Basic Auth, SMTP