PRB: Email gateway user list does not show all available mailboxes on domain
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ZTN2161
This Zetafax technical note applies to:
- Zetafax Version 17.5 using Exchange Online email gateway
Symptom
In some instances, after refreshing the list of email gateway users, which imports user email addresses from Exchange Online, the full list of users may not appear and it is therefore not possible to enable users by their emails.
Cause
There is a known issue with Zetafax fetching user email addresses whereby if the underlying Microsoft Graph API pages the data returned to Zetafax, then Zetafax does not receive the full list of users.
Resolution
There are 2 workarounds for this issue. One is to use the auto enrollment feature, which allows enabling of a wildcard domain name, with new email senders added automatically as users (see https://www.equisys.com/support/help_and_resource/zetafax/help/setup/index.html?auto_enrolment.htm).
The second option is to create a new Zetafax User from the Zetafax Users list rather than the Email Gateway Users list.
1. Right click on the Zetafax users option in the Zetafax Configuration Program and click 'Add New Zetafax User'.
2. Type in the Zetafax username you want to use
3. Fill in the fields required, taking note of the tickboxes for email gateway sending and receiving. Fill in the 'email user name' field with the SMTP email address of the user
4. Click OK.
Once these steps are completed, the user is now enabled.
Status
Equisys is aware of this issue and will update this technical note when a solution has been found.
Last updated: 2nd January 2024 (NT)
Keywords: GAL Azure AD Entra