PRB: "There is no user in the Expenses system for this Microsoft Work or School Account. Contact your System Administrator" error appears when attempting to log in to Expenses Administration site
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ZTN6016
This Zetadocs technical note applies to:
Symptom
When a user set up as an Administrator attempts to login to the Zetadocs Expenses Administration site using a Microsoft work or school account, they receive an error stating that "There is no user in the Expenses system for this Microsoft Work or School Account. Contact your System Administrator". The user is able to sign into the Zetadocs Expenses client without problems.
Cause
This occurs when the username of the user is changed in Azure AD (for instance, when a company name change triggers a change domain) and results in there being 2 different addresses within Azure AD (the UserPrincipalName, used to log in, is the new address, but the primary email address listed is still using the old domain). The error appears because Zetadocs Expenses Client uses the UserPrincipalName to match the Zetadocs Expenses user for logging in but the Administration site uses the email address.
Resolution
As a workaround, users can be setup to allow sign in with a Zetadocs Account to be able to log in to the Administration site.
Status
Equisys is aware of this issue and will update this technical note when a solution has been found.
Last updated: 8th July 2021 (NU/NT)
Keywords: Company name change