Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Zetadocs Expenses report fails to export with error in logs: 'The HTTP request is unauthorized with client authentication scheme 'Negotiate'

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ZTN6015

This Zetadocs technical note applies to:

  • Zetadocs expenses connector (On-Premises) all versions
  • All versions of NAV and Business Central On-Premises

Symptom

This technote is for when you are experiencing issues with exporting expenses into your NAV or Business central environment when you are using the Expenses Connector and you see the following error within the ZetadocsExpense.log file:

The connector logs show the following error:

"e38321ce_6318_4089_971a_143ae77d2193 19/04/2021 15:14:55.176 Error 38 ConnectorCore.ExportExpenses[187] Exception was thrown 'The HTTP request is unauthorized with client authentication scheme 'Negotiate'. The authentication header received from the server was 'Negotiate'.' of type System.ServiceModel.Security.MessageSecurityException, System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089;Connector Request: ExportExpensesToBusinessCentral"

Cause

The reason for this is due to the account which runs the Expenses connector service not having correct permissions to NAV/BC or being prompted for username and password when connecting. The software is expecting to connect to the NAV/BC environment without needing to authenticate again to the system. 

A way to check this is to do the following:

  1. Find the Expenses web service endpoint URL from NAV/BC and copy this.
  2. Run a browser as the user running the Zetadocs Expenses connector service.
  3. Paste the URL into the address bar and go to this service.

We are expecting the service to load in the browser with no prompt for a username and password.

Resolution

If you are getting prompted for a username and password, either the account does not have the required permissions, or you may need to change the authentication type of your NAV/BC service to username/password. Please verify your SSL settings or speak to your NAV/BC VAR or Microsoft if you require further assistance with changing the authentication type of your NAV/BC environment.

Status

The behaviour of the software versions given above is as designed.

Last updated: 24th June 2021 (EG) 

Keywords: BC on prem, Export failed

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