FIX: CAPI devices take a long time to initialize
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ZTN1715
ID: ZTN1715
This Zetafax technical note applies to:
- Zetafax version 2006 and later.
Symptom
When starting the Zetafax Server CAPI devices take a minimum of 6 seconds per device to initialize. The following can be seen in the logs:
08-11-04 13:35:51 SYSMAN - (I) - Started program CAPI-1
08-11-04 13:35:51 CAPI-1 - (I) - Device controller for CAPI-1 - Version 10.0.402
08-11-04 13:35:51 CAPI-1 - (I) - First page resent if call interrupted
08-11-04 13:35:51 CAPI-1 - (I) - Using CAPI controller number 1 - Dialogic Corporation (formerly Eicon Networks) (Serial #11-1)
08-11-04 13:35:51 CAPI-1 - (I) - Initialising CAPI session
08-11-04 13:35:51 CAPI-1 - (I) - CAPI session initialised successfully
08-11-04 13:35:57 SYSMAN - (I) - Started program PRINT-1
Cause
This is due to some redundant actions being performed during initialization.
Resolution
To resolve this problem, please perform the steps below. Once complete, CAPI devices should initialize in 2-3 seconds per device:
1) Extract the hotfix files provided to a temporary location, e.g. c:\temp\
2) Stop the Zetafax Server.
3) Browse to < program files> \Zetafax Server\Server.
4) Rename Devcapi.exe to Devcapi.exe.old.
5) Copy the new files provided (Devcapi.exe) into your < program files> \Zetafax Server\SERVER\ folder. Ensure that the file version is 12.1.677.
6) Start the Zetafax Server. Your Zetafax Server Monitor should show the CAPI devices initializing in 2-3 seconds as shown below:
08-11-04 11:36:18 SYSMAN - (I) - Started program CAPI-1
08-11-04 11:36:18 CAPI-1 - (I) - Device controller for CAPI-1 - Version 12.1.677
08-11-04 11:36:18 CAPI-1 - (I) - First page resent if call interrupted
08-11-04 11:36:18 CAPI-1 - (I) - Using CAPI controller number 1 - Dialogic Corporation (formerly Eicon Networks) (Serial #11-1)
08-11-04 11:36:18 CAPI-1 - (I) - Initialising CAPI session
08-11-04 11:36:18 CAPI-1 - (I) - CAPI session initialised successfully
08-11-04 11:36:20 CAPI-1 - (I) - Device status now IDLE
Status
This behaviour was corrected as a hot-fix. Please contact Equisys support for download instructions.
Last updated: 2nd December 2008 (HP/GC/MW)
Keywords: Zetafax Server