Equisys technical notes

Technical guidance, explanations and fixes for our products

FIX: Combining TIFF/TIF files from the Zetadocs PDF Client causes the client to crash.

Print

ZTN4165

ID: ZTN4165

This Zetadocs technical note applies to:

  • Zetadocs PDF Client v7.1 and earlier.

Symptom

When attempting to combine a TIFF/TIF file to a new or existing document from the Zetadocs PDF Client,
the following error is displayed “No application is associated with the specified file for this operation”:



Cause

When combining a TIFF/TIF file, the Zetadocs PDF Client is looking for the associated application to proceed. This can cause the Zetadocs Client to give the error above, if the file association of the TIFF/TIF type is broken. This can happen if, for example, Microsoft Office Service Packs have been installed for Office 2003 which Microsoft has reported as a known issue:
            http://support.microsoft.com/kb/967055/
            http://support.microsoft.com/kb/967054/
 

Resolution

This problem can be resolved by doing the following:

  • Download the following file:
  • Extract this archive to a location you can easily access.
  • Open the following registry keys depending of the version of your system
    • For XP:             Extracted Archive / XP / tiff_fix_xp.reg
    • For Vista:          Extracted Archive / Vista / tiff_fix_vista.reg
    • For Windows 7  Extracted Archive / Windows7 / tiff_fix_w7.reg
  • These registry keys will set the TIFF/TIF file association back to its default value.

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Equisys cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved.

Status

This has been identified by Equisys as an issue with the software versions given above.

Last updated: 11th January 2012 (SD/MW)

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script