Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Messages get stuck in MTS-IN Queue in Exchange Server 2003

Print

ZTN1531

ID: ZTN1531

This Zetafax technical note applies to:

  • Zetafax v.8 and later using Zetafax Connector on Exchange Server 2003

Symptom

The Zetafax server reports that incoming faxes are being passed to the Email Gateway, but users do not receive incoming faxes into their Outlook inboxes. The messages get stuck in the MTS-IN Queue in Exchange System Manager.

Cause

Due to an Exchange server 2003 security patch, the Zetafax Connector functions with insufficient permissions resulting in messages getting stuck in the MTS-IN queue.

Resolution

Firstly, you need to check if the Zetafax Connector is using an "orphaned" ZFConnector mailbox or if there is more than 1 ZFConnector mailbox.

Run the application ADSI Edit (Start Menu\Programs\Windows 2000/3 Support Tools\Tools)

WARNING: Using ADSI edit (Active Directory Services Information Editor) incorrectly can cause serious problems with your Active directory network services that may require disaster recovery. Equisys cannot guarantee that problems resulting from the incorrect use of ADSI Editor can be solved. Use ADSI edit at your own risk. For information about ADSI edit, view the Help topic in ADSI edit.

Expand Configuration and browse to

CN=Services ->
CN=Microsoft Exchange ->
CN=First Organisation ->
CN=First Organisation ->
CN=Administrative Groups ->
CN=First Administrative Group ->
CN=Routing Groups ->
CN=First Routing Group ->
CN=Connections

There should only be one instance of the ZFConnector in here and it should be like

CN=ZFConnector(domain name)

If there is more than one, delete the entry that has NO brackets.

  • Check the Mailboxes tree in Exchange System Manager to see if a ZFConnector mailbox is there.
  • Right-click Mailboxes and choose Run Cleanup agent. If the ZFConnector is an "orphaned" mailbox it will be marked with a red cross; if it is, purge it by right-clicking the mailbox - choose Purge.

Secondly, you need to create and run the Zetafax Connector service under a different account. Permissions need to be modified in Exchange System Manager.

You need to create a new domain user and assign the user rights to all the mailboxes in the whole organization by changing the permissions on the organization object at the top of the Exchange System Manage tree.

Refer to the resolution section of ZTN1490-PRB Zetafax Connector service fails to start when set to use the local system account.doc for more information on creating this user account if the Exchange Server resides on a Member Server or a Domain Controller. Once done, start the Zetafax Connector under this account.

There is no way of retrieving the existing messages from the MTS-IN queue unless the Zetafax Connector is reinstalled. However new messages will go through successfully now.

Status

This has been identified by Equisys as a problem with the software versions given above.


Last updated: 28th June 2006 (AC/EB)



Keywords: < MTS-IN> < Connector>

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script