Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Reports created with the Zetadocs for NAV Report Tool on a machine with different date formatting to the NAV server causes an error on import

Print

ZTN4217

ID: ZTN4217

This Zetadocs technical note applies to:

  • Version 4.2 of Zetadocs for Microsoft Dynamics NAV and later

Symptom

On importing reports modified with the Zetadocs for NAV Report Tool an error message is displayed highlighting an incompatibility with the date formatting.

Cause

If the Zetadocs for NAV Report Tool is used to modify Microsoft Dynamics NAV reports, on a machine with different date format settings, to the NAV server, these settings are detected and used in the creation of the modified report. This causes an incompatibility with the NAV system from which the reports were exported.

Resolution

The issue can be avoided by ensuring that the machine used to create the modified reports with the Zetadocs for NAV Report Toolhas the same date format settings as the NAV server being used. Ideally you may wish to run the tool on the actual NAV server to ensure that this issue does not occur.

Status

This issue can be avoided using the above workaround.

Last Updated 10th December 2012 (MW/)

Equisys Logo, Document Management and Expense Management for Business Central
 

Replaced by script