PRB: SOAP connection does not work if Internet Explorer is configured to use a proxy
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ZTN2011
ID: ZTN2011
This Zetalink technical note applies to:
Symptom
Users are able to browse to the start page on the Zetalink External Web Site and enter their PIN number. However when the select the 'Logon' link or button they then receive a 'system error' message.
Cause
The Internet Explorer settings on the Internet Information server (IIS) hosting the Zetalink External Web Site are configured to use a proxy server. The Zetalink External Web Site component is also configured to use SOAP to communicate with Zetalink server.
The Microsoft SOAP components (used by Zetalink to implement SOAP on Windows platforms) do not automatically use the proxy settings configured for Internet Explorer, therefore they are unable to use HTTP to connect to the 'SOAP support' components on the Zetalink server machine.
Resolution
The Zetalink External Web Site component can be configured to force the Microsoft SOAP components to use proxy settings. This is achieved by editing the registry:
WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Equisys cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.
For information about how to edit the registry, view the " Changing Keys and Values" Help topic in Registry Editor (REGEDIT.EXE) or the " Add and Delete Information in the Registry" and " Edit Registry Data" Help topics in REGEDT32.EXE. Note that you should back up the registry before you edit it. If you are running Windows NT or Windows 2000, you should also update your Emergency Repair Disk (ERD).
- Start Registry Editor on the IIS server hosting the Zetalink External Web Site.
- Locate the following key in the registry:
HKEY_LOCAL_MACHINE\SOFTWARE\Equisys\Zetalink\IISUIP
- Add the DWORD entry below and set the value:
Use Proxy for SOAP |
0 is disabled, 1 is enabled. |
- Close Registry Editor.
Status
This has been identified by Equisys as a problem with the software versions given above.
Last updated: 15 November 2001 (GS/DH)