ID: ZTN4449
This Zetadocs technical note applies to:
Symptom
In some circumstances, the following warning dialog appears when installing the Zetadocs Express Client: Microsoft Dynamics NAV 2009 R2, 2013 or 2015 Role Tailored Client needs to be installed for this installation to continue.
This is more likely to occur on systems that have, or have had, multiple versions of NAV installed.
Cause
The Zetadocs Express installer checks for a supported version of NAV, and also the NAV Role Tailored Client path in the registry prior to installation, to ensure that NAV is installed on the system and is a supported version.
In some systems, it appears that the registry keys that are normally associated with a normal installation of NAV do not exist, which results in the warning dialog popping up and the install being terminated.
Resolution
If a valid version of NAV is installed, please attempt a repair of the NAV install. Note that the Zetadocs Express Client will install for the last version of NAV that was installed on the system.
WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Equisys cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved.
If the repair fails to rectify the issue, please add the following keys to the 32 bit section of the registry (Wow6432Node in 64 bit systems) if they do not already exist:
For NAV 2009 R2:
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\DynamicsNAV60
Attribute name: DisplayVersion
Type: REG_SZ
Data: 6.1.0.0
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ {00000000-0000-6002-0020-0000836BD2D2}
Attribute name: DisplayVersion
Type: REG_SZ
Data: 6.1.0.0
For NAV 2013:
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\DynamicsNAV70
Attribute name: DisplayVersion
Type: REG_SZ
Data: 7.0.0.0
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ {00000000-0000-7000-0000-0CE90DA3512B}
Attribute name: DisplayVersion
Type: REG_SZ
Data: 7.0.0.0
For NAV 2013 R2:
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\DynamicsNAV71
Attribute name: DisplayVersion
Type: REG_SZ
Data: 7.1.0.0
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ {00000000-0000-7100-0000-0CE90DA3512B}
Attribute name: DisplayVersion
Type: REG_SZ
Data: 7.1.0.0
For NAV 2015:
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\DynamicsNAV80
Attribute name: DisplayVersion
Type: REG_SZ
Data: 8.0.0.0
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ {00000000-0000-8000-0000-0CE90DA3512B}
Attribute name: DisplayVersion
Type: REG_SZ
Data: 8.0.0.0
For NAV 2016:
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\DynamicsNAV90
Attribute name: DisplayVersion
Type: REG_SZ
Data: 9.0.0.0
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ {00000000-0000-9000-0000-0CE90DA3512B}
Attribute name: DisplayVersion
Type: REG_SZ
Data: 9.0.0.0
For all NAV versions:
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\Microsoft.Dynamics.Nav.Client.exe
Attribute name: Path
Type: REG_SZ
Data:
Where is the local path to the NAV Role Tailored Client folder (e.g. C:\Program Files (x86)\Microsoft Dynamics NAV\80\RoleTailored Client\)
Please note that the absence of certain registry keys may result in other issues unrelated to Zetadocs on your NAV installation. The steps above will simply allow installation of the Zetadocs components.
Status
This issue is caused by a third party component we will update this technote when a solution to this issue becomes available.
Last updated: 14th March 2016 (NT)
Keywords: ZDX install failure error