Equisys technical notes

Technical guidance, explanations and fixes for our products

PRB: Zetafax service unable to log onto Lotus Notes when user logs off the NT desktop

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ZTN1063

ID: ZTN1063

This Zetafax technical note applies to:

  • Zetafax 5.5 and later
  • Lotus Notes 4.x and later

Symptoms

This affects the Zetafax e-mail gateway module STM32.EXE and the least cost routing module ROUTER.EXE if configured with Lotus Notes/Domino server. If installed on NT, Zetafax may be run in the background as an 'NT' service. Once running as a service, if you log off the current user session the Zetafax service will continue to run however STMAIL will report 'Unable to link with the device', and ROUTER says 'Lotus Notes reports 'Operation stopped at your request''.

Cause

Zetafax uses the NSFDbOpen function that is supplied in the Notes API. The service starts correctly and can open databases remotely until the current user logs off the NT desktop.  At this point, the following error message is returned by the program, specifically the NSFDbOpen() call: " Operation stopped at your request." This is interpreted by STMAIL as 'Unable to link with the device' and logs this in the zfax\SERVER\Z-DB\SERVER.LOG, where 'zfax' is the name of the directory where the Zetafax server files are installed.

Resolution

Zetafax server service needs to set an NT environment variable when it starts up.

To achieve this, point to Start> Settings> Control Panel and launch the 'System' applet.

  1. Click on the Environment tab and highlight the 'System variables' and enter a new variable as follows:

Variable:

NOTESNTSERVICE

Value:

1

and click 'Set'.

  1. Confirm the new variable has been entered under 'System variables' and restart the Zetafax service.

Status

This has been identified by Equisys as a fault with the modules STM32.EXE and ROUTER.EXE.

Last updated: 21 March 2000 (GC/DH)

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